import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " \n"
+ " (?: # ----------\n"
+ " (?= (?&V_Obj) ) # Assertion : Must be a Valid JSON Object\n"
+ " \\{\n"
+ " | # or ,\n"
+ " (?! ^ ) # Here we are in a valid JSON Object or Array\n"
+ " \\G # Continuation anchor, where we last left off\n"
+ " (?&Sep_Obj) \\s* # Array Separator\n"
+ " ) # ----------\n"
+ " \n"
+ " (?: (?&V_KeyVal) (?&Sep_Obj) )*? # Drill down to array or string value\n"
+ " \n"
+ " \\s* \\K # Stop recording\n"
+ " ( (?&Str) ) # (1), The key\n"
+ " \\s* : \\s* \n"
+ " \n"
+ " (?| # Branch reset\n"
+ " \\[ # Array values = string, numb, bool, or null\n"
+ " ( # (2), Array Contents\n"
+ " (?:\n"
+ " \\s* \n"
+ " (?:\n"
+ " (?&Numb) # Numbers\n"
+ " | (?> true | false | null ) # Boolean and null\n"
+ " | (?&Str) # String\n"
+ " )\n"
+ " (?&Sep_Ary) # Ary separator\n"
+ " )+\n"
+ " )\n"
+ " \\s* \\] \n"
+ " | # Or,\n"
+ " ( # (2), A Non-Ary, Non-Obj value\n"
+ " (?&Numb) # Numbers\n"
+ " | (?> true | false | null ) # Boolean and null\n"
+ " | (?&Str) # String\n"
+ " )\n"
+ " )\n"
+ " \n"
+ " # JSON functions - NoErDet\n"
+ " # ---------------------------------------------\n"
+ " (?(DEFINE)(?<Sep_Ary>\\s*(?:,(?!\\s*[\\}\\]])|(?=\\])))(?<Sep_Obj>\\s*(?:,(?!\\s*[\\}\\]])|(?=\\})))(?<Str>(?>\"[^\\\\\"]*(?:\\\\[\\s\\S][^\\\\\"]*)*\"))(?<Numb>(?>[+-]?(?:\\d+(?:\\.\\d*)?|\\.\\d+)(?:[eE][+-]?\\d+)?|(?:[eE][+-]?\\d+)))(?<V_KeyVal>(?>\\s*(?&Str)\\s*:\\s*(?&V_Value)\\s*))(?<V_Value>(?>(?&Numb)|(?>true|false|null)|(?&Str)|(?&V_Obj)|(?&V_Ary)))(?<V_Ary>\\[(?>\\s*(?&V_Value)(?&Sep_Ary))*\\s*\\])(?<V_Obj>\\{(?>(?&V_KeyVal)(?&Sep_Obj))*\\s*\\}))\n";
final String string = "{\n"
+ " \"key1\":\n"
+ " [\"value1\",\"value2\",\"value3\",\"value4\",\"value5\",3.14,null],\n"
+ " \"key_complex_skip\":\n"
+ " [\"valuec\", {\"subkey\": [null,null,34.123] } ],\n"
+ " \"key2\":\n"
+ " null,\n"
+ " \"key3\":\n"
+ " \"value8\"\n"
+ "}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}