package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(20)\d{2}(0[1-9]|1[0-2])(0[1-9]|[12][0-9]|3[01])\d{6}_(.*)\b`)
var str = `20240117130800_works
20250801144000_works
202405231637_missing_two_time_values
20251301144000_invalid_month
20251232144000_invalid_day
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}