$re = '/\b(20)\d{2}(0[1-9]|1[0-2])(0[1-9]|[12][0-9]|3[01])\d{6}_(.*)\b/m';
$str = '20240117130800_works
20250801144000_works
202405231637_missing_two_time_values
20251301144000_invalid_month
20251232144000_invalid_day
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);