package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\D*(?:\d+\D+){2}$`)
var str = `There were 3 cars going over 45 miles per hour`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}