$re = '/^\D*(?:\d+\D+){2}$/m';
$str = 'There were 3 cars going over 45 miles per hour';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);