import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\d{0,3}[a-z]{1,3}\\d{1,3})+|(?:[a-z]{0,3}\\d{1,3}[a-z]{1,3})+)$";
final String string = "i7g172w2n\n"
+ "adab172cd\n"
+ "aaa172afa\n"
+ "ab21cd172\n"
+ "abc21a3d3\n"
+ "abc2p7373";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}