import re
regex = re.compile(r"^(?:(?:\d{0,3}[a-z]{1,3}\d{1,3})+|(?:[a-z]{0,3}\d{1,3}[a-z]{1,3})+)$", flags=re.MULTILINE)
test_str = ("i7g172w2n\n"
"adab172cd\n"
"aaa172afa\n"
"ab21cd172\n"
"abc21a3d3\n"
"abc2p7373")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")