re = /^(?:(?:\d{0,3}[a-z]{1,3}\d{1,3})+|(?:[a-z]{0,3}\d{1,3}[a-z]{1,3})+)$/m
str = 'i7g172w2n
adab172cd
aaa172afa
ab21cd172
abc21a3d3
abc2p7373'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end