#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).{20}(?=\[.+?\])"
Local $sString = "File description that is waaay too long for Windows ABCD [General_123].doc" & @CRLF & _
"File description that is waaay too long for Windows AB123 [General_456].docx" & @CRLF & _
"Spreadsheet for Year 2023 with a too long name [General_159].xls"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")