import re
regex = re.compile(r".{20}(?=\[.+?\])", flags=re.MULTILINE)
test_str = ("File description that is waaay too long for Windows ABCD [General_123].doc\n"
"File description that is waaay too long for Windows AB123 [General_456].docx\n"
"Spreadsheet for Year 2023 with a too long name [General_159].xls")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")