#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*"hide"\s*:\s*true.*(*SKIP)(*FAIL)|"user"\s*:\s*"\K[^"]+"
Local $sString = "<!-- block {"user":"josh-hart", 1234566 ,"hide":false} /-->" & @CRLF & _
"<!-- block {"user":"jalen-brunson", 7744633 ,"hide":true} /-->" & @CRLF & _
"<!-- block {"user":"julius-randle", 333333,"hide":false} /-->" & @CRLF & _
"<!-- block {"user":"obi-toppin", 4hh3n33n33n, /-->" & @CRLF & _
"<!-- block {"user":"rj-barrett", nmremxxx!! ,"hide":true} /-->" & @CRLF & _
"<!-- block {"user":"mitch-robinson",yahaoao /-->"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")