re = /^.*"hide"\s*:\s*true.*(*SKIP)(*FAIL)|"user"\s*:\s*"\K[^"]+/m
str = '<!-- block {"user":"josh-hart", 1234566 ,"hide":false} /-->
<!-- block {"user":"jalen-brunson", 7744633 ,"hide":true} /-->
<!-- block {"user":"julius-randle", 333333,"hide":false} /-->
<!-- block {"user":"obi-toppin", 4hh3n33n33n, /-->
<!-- block {"user":"rj-barrett", nmremxxx!! ,"hide":true} /-->
<!-- block {"user":"mitch-robinson",yahaoao /-->'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end