import re
regex = re.compile(r"^.*\"hide\"\s*:\s*true.*(*SKIP)(*FAIL)|\"user\"\s*:\s*\"\K[^\"]+", flags=re.MULTILINE)
test_str = ("<!-- block {\"user\":\"josh-hart\", 1234566 ,\"hide\":false} /-->\n"
"<!-- block {\"user\":\"jalen-brunson\", 7744633 ,\"hide\":true} /-->\n"
"<!-- block {\"user\":\"julius-randle\", 333333,\"hide\":false} /-->\n"
"<!-- block {\"user\":\"obi-toppin\", 4hh3n33n33n, /-->\n"
"<!-- block {\"user\":\"rj-barrett\", nmremxxx!! ,\"hide\":true} /-->\n"
"<!-- block {\"user\":\"mitch-robinson\",yahaoao /-->")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")