#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(^([0-9[:punct:]0-9]+|\p{No}|\d\p{No}) ?\s* ?([0-9[:punct:]0-9]+|\p{No}|\d\p{No})* ?\w* (cup|tsp|tbps|tablespoon|teaspoon|small|medium|pint|ounce|pound))|(^(small|Large|medium|Fresh))"
Local $sString = "Should match:" & @CRLF & _
"1 Cups" & @CRLF & _
"2 tsp" & @CRLF & _
"3 tbps" & @CRLF & _
"1/2 tablespoon" & @CRLF & _
"3 tablespoons" & @CRLF & _
"1 tablespoon" & @CRLF & _
"3 teaspoons" & @CRLF & _
"1 small" & @CRLF & _
"Small chiles" & @CRLF & _
"23 Small chiles" & @CRLF & _
"1/2 a Small chile" & @CRLF & _
"1 1/2 cups kewpie" & @CRLF & _
"11/2 cups kewpie" & @CRLF & _
"1/3 cup fresh lemon juice" & @CRLF & _
"1 medium onion" & @CRLF & _
"Large" & @CRLF & _
"medium" & @CRLF & _
"Freshly" & @CRLF & _
"1½ cups Kewpie" & @CRLF & _
"½ cups Kewpie" & @CRLF & _
"1 pint" & @CRLF & _
"4 ounces" & @CRLF & _
"1 pound" & @CRLF & _
"2 pounds" & @CRLF & _
"" & @CRLF & _
"Should not match:" & @CRLF & _
"" & @CRLF & _
"1 Make the sauce" & @CRLF & _
"1 toast the bread" & @CRLF & _
"I want to make 1 piece of toast"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")