# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^([0-9[:punct:]0-9]+|\p{No}|\d\p{No}) ?\s* ?([0-9[:punct:]0-9]+|\p{No}|\d\p{No})* ?\w* (cup|tsp|tbps|tablespoon|teaspoon|small|medium|pint|ounce|pound))|(^(small|Large|medium|Fresh))"
test_str = ("Should match:\n"
"1 Cups\n"
"2 tsp\n"
"3 tbps\n"
"1/2 tablespoon\n"
"3 tablespoons\n"
"1 tablespoon\n"
"3 teaspoons\n"
"1 small\n"
"Small chiles\n"
"23 Small chiles\n"
"1/2 a Small chile\n"
"1 1/2 cups kewpie\n"
"11/2 cups kewpie\n"
"1/3 cup fresh lemon juice\n"
"1 medium onion\n"
"Large\n"
"medium\n"
"Freshly\n"
"1½ cups Kewpie\n"
"½ cups Kewpie\n"
"1 pint\n"
"4 ounces\n"
"1 pound\n"
"2 pounds\n\n"
"Should not match:\n\n"
"1 Make the sauce\n"
"1 toast the bread\n"
"I want to make 1 piece of toast")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.