#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)class=\"four-column mosaicElement\">\R<a href=\"(.+?)\" title=\"(.+?)"
Local $sString = "<li class="four-column mosaicElement">" & @CRLF & _
"<a href="https://example.com" title="Lorem ipsum">" & @CRLF & _
"..." & @CRLF & _
"</a>" & @CRLF & _
"</li>" & @CRLF & _
"<li class="four-column mosaicElement">" & @CRLF & _
"<a href="https://example.org" title="Lorem ipsum">" & @CRLF & _
"..." & @CRLF & _
"</a>" & @CRLF & _
"</li>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")