// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)class=\"four-column mosaicElement\">\R<a href=\"(.+?)\" title=\"(.+?)"#).unwrap();
let string = "<li class=\"four-column mosaicElement\">
<a href=\"https://example.com\" title=\"Lorem ipsum\">
...
</a>
</li>
<li class=\"four-column mosaicElement\">
<a href=\"https://example.org\" title=\"Lorem ipsum\">
...
</a>
</li>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}