re = /class=\"four-column mosaicElement\">\R<a href=\"(.+?)\" title=\"(.+?)/m
str = '<li class="four-column mosaicElement">
<a href="https://example.com" title="Lorem ipsum">
...
</a>
</li>
<li class="four-column mosaicElement">
<a href="https://example.org" title="Lorem ipsum">
...
</a>
</li>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end