import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "0[xX][0-9a-fA-F]+(?=\\nwtf)";
final String string = "1616846098450\n"
+ "trying : 16633299966633299966633299\n"
+ "0x4d68c66a4b7ac51f87e22d0e0b70a4ebc7f6286e7834ec3da18c6147f578afe8\n"
+ "wtf\n"
+ "0x848fcea771facf657677f1f3a919ab7e43b1f7d0df95bf8375113c5621e063c2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}