const regex = /0[xX][0-9a-fA-F]+(?=\nwtf)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0[xX][0-9a-fA-F]+(?=\\nwtf)', 'gm')
const str = `1616846098450
trying : 16633299966633299966633299
0x4d68c66a4b7ac51f87e22d0e0b70a4ebc7f6286e7834ec3da18c6147f578afe8
wtf
0x848fcea771facf657677f1f3a919ab7e43b1f7d0df95bf8375113c5621e063c2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}