import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[, ]*\\b[db]+y?[iunb]{1,2}[okgbil]{1,3}[nhei]{1,2} *(\\d)";
final String string = "27 gloonlara road, finglas, dulbin 11\n"
+ "apt 3 block 10 gallery quay, grand canal square dublini 2\n"
+ "17 block c doonbeg house, clare village, clare hall dublin17\n"
+ "1 waverley terrace, kenilworth square, dublin6\n"
+ "19 ardmore close, artane, dublin 5\n"
+ "71 powers court, mount street, dublin2\n"
+ "apartment 93, 20 christchurch place, dubin 8\n"
+ "15 ebenezer terrace, donor avenue, inchicore dubllin 8\n"
+ "54 burnell park avenue, castleknock, dubin 15\n"
+ "351 bachelors walk, dublin1\n"
+ "apt 43 st. anthony's walk, rialto, dublin8\n"
+ "apartment33 block d, doolin house, clare village clare hall dublin17\n"
+ "40 coolatree park, beaumont, bublin 9\n"
+ "57 bellville, navan road, dublin15\n"
+ "2 belgard close, tallaght, dublin24\n"
+ "51 the coombe, dubliln 8\n"
+ "21 walkinstown park, walkinstown, diblin 12\n"
+ "apt 77 millpark, clondalkin, dublin 22\n"
+ "71 tudor lawns, foxrock, dublni 18\n"
+ "38 bayside crescent, sutton, dublin13\n"
+ "5 bancroft close, tallaght, dublin 24\n"
+ "apt 18 no 68 jervis street, dublin1\n"
+ "8 the friary, bluebell, dublin12\n"
+ "64 cremorne, terenure, dubin 6\n"
+ "1 elmwood close, clonsilla, dublinn 15\n"
+ "19 woodstown place, knocklyon, dubin 16\n"
+ "11 monksfield heights, clondalkin, dublin22\n"
+ "2 st. declans tce, marino, dublin3\n"
+ "apartment 28, block a kilkee house, clare village clare hall dublin17\n"
+ "33 tulla house, clare village, dubllin 17\n"
+ "71 donnycarney road, whitehall, dubin 9\n"
+ "46 casement park, finglas, dublin11\n"
+ "15 block e3 ennis house, clare village, clare hall dublin17\n"
+ "13 blarney park, kimmage, dubin 12\n"
+ "47 ennis house, clare village clare hall, dublin17\n"
+ "6 ennis house, clare village, dublin13\n"
+ "30 newlands road, clondalkin, dubllin 22\n"
+ "33 kings avenue, dubiln 3\n"
+ "46 block e3 ennis house, clare village clare hall, dublin17\n"
+ "69 churchwell road, belmayne, balgriffin dublin13\n"
+ "64 st. davids park, artane, dublin 5\n"
+ "11 cairnbrook avenue, carrickmines, dublin 18\n"
+ "78 hunter's walk, hunterswood, ballycullen dubin 24\n"
+ "no198, lower kimmage road, dublin6\n"
+ "20 kelston drive, foxrock, dubllin 18\n"
+ "no 5 swift hall carrickmines wood, brennanstown road dubiln 18\n"
+ "32 ballytore road, rathfarnham park, dublin 14\n"
+ "70 hillcrest park, glasnevin, dublin11\n"
+ "4 st. patrick's cottages, rathfarnham, dbulin 14\n"
+ "35 johnstown court, cabinteely, dublon 18\n"
+ "28 ashford st, dublin 7\n"
+ "32 villiers road, rathgar, dublin6\n"
+ "apt 19 mellor court, 19-23 liffey street lower, duboin 1\n"
+ "15 all saints road, raheny, dublin5\n"
+ "64 saul road, crumlin, dublin12\n"
+ "10 blackheath court, clontarf, dublin3\n"
+ "11 grangeview close, clondalkin, dublin 22\n"
+ "128 kildare road, crumlin, dublin12\n"
+ "39 woodstown way, knocklyon, dublin16\n"
+ "23 rothe abbey, kilmainham, dublin8\n"
+ "50 collinswood, collins avenue, dublin9\n"
+ "24 tritonville road, sandymount, dublin 4\n"
+ "139 belmont park, raheny, dublin5\n"
+ "1 deerhaven crescent, clonee, dublin15\n"
+ "15 monastery heath square, clondalkin, dublin22\n"
+ "15 brookwood park, artane, dublin 5\n"
+ "300 navan road, dublin7\n"
+ "17b merlyn park, ballsbridge, dunlin 4\n"
+ "84 tritonville road, sandymount, dublbin 4\n"
+ "16 windsor terrace, portobello, dublin8\n"
+ "1 whitton road, terenure, diblin 6w\n"
+ "1 eagle hill avenue, terenure road east, dubliln 6w\n"
+ "25 gullistan cottages, rathmines, dublin6\n"
+ "409 castleforbes square, upper mayor street, dublin1\n"
+ "439 castleforbes square, upper mayor street, dublin1\n"
+ "94 phibsboro road, phibsboro, dublin7\n"
+ "45 shanglass road, whitehall, dublin9\n"
+ "12 st bricins park, dubliin 7\n"
+ "20 greenhills road, walkinstown, dubln 12\n"
+ "112 malahide road, clontarf, dubiln 3\n"
+ "55 mountshannon road, rialto, dublin8\n"
+ "46 foster terrace, dubiln 3\n"
+ "3 rosemount, malahide road, dubin 5\n"
+ "4 castle avenue, upr churchtown road, dubliln 14\n"
+ "188 bushy park house, templogue road, terenure dublin6\n"
+ "11 greenlea park, terenure, dubln 6w\n"
+ "54 wood dale view, ballycragh, dubln 24\n"
+ "2 glenfield avenue, clondalkin, dublin 22\n"
+ "34 grange manor drive, rathfarnham, dublin16\n"
+ "33 monksfield grove, clondalkin, dublin22\n"
+ "41 philipsburgh terrace, marino, dublin3\n"
+ "85 bluebell road, bluebell, dublin12\n"
+ "11 the garth kingswood heights, clondalkin, dublin22\n"
+ "5 mount eagle grove, leopardstown heights, leopardstown dublin18\n"
+ "34 donore road, south circular road, dublin8\n"
+ "65 sutton park, sutton, dublin13\n"
+ "51 briarfield road, kilbarrack, dubln 5\n"
+ "4 drumfinn avenue, ballyfermot, dulin 10\n"
+ "31 gullistan cottages, rathmines, dublin6\n"
+ "40 pinewood park, rathfarnham, dubiln 14\n"
+ "64 the waterside, charlotte quay, dublin4\n"
+ "2 barnwell way, hansfield, dubin 15\n"
+ "111 pine valley avenue, rathfarnham, dubkin 16\n"
+ "30 ratra park, dublin 7\n"
+ "3 blakestown road, mulhuddart, dubliln 15\n"
+ "22 foyle road, fairview, dubln 3\n"
+ "apt. 125 bachelor's walk, dublin 1\n"
+ "31 summerhill parade, dulin 1\n"
+ "88 meadow grove, dundrum, dubglin 14\n"
+ "4 kickham road, inchicore, dublin 8\n"
+ "52 hazelwood avenue, clonsilla, dublin15\n"
+ "4 rathdown square, phibsboro, dublin 7\n"
+ "14a kincora court, clontarf, dublin3\n"
+ "apartment 26, 35 mountjoy square, dublin1\n"
+ "3 drummartin crescent, goatstown, dublin 14\n"
+ "15 the court, kingswood heights, dublin24\n"
+ "78 greentrees road, perrystown, dublin12\n"
+ "27 kiltipper avenue, tallaght, dubblin 24\n"
+ "112 rafters road, drimnagh, dublin12\n"
+ "3 barnwell terrace, hansfield, dubin 15\n"
+ "40 the maples, clonskeagh, dublin 14\n"
+ "48 alderwood, hollystown, dublin15\n"
+ "43 millcourt avenue, clondalkin, dublin 22\n"
+ "129 belmont park, raheny, dublin 5\n"
+ "67 swanward court, parnell road, dublin 8\n"
+ "111 whitethorn drive, palmerstown, dublin 22\n"
+ "36 sundale avenue, tallaght, dublin24\n"
+ "26 mount alton, knocklyon, dublin16\n"
+ "41 kirkpatrick house, spencer dock, dublin1\n"
+ "34 niall street, stoneybatter, dublin7\n"
+ "59a foxrock park, foxrock, dublin18\n"
+ "11 the cobbles, wellington quay, dublin2\n"
+ "24 palmers court, palmerstown, dublin 20\n"
+ "11 fernwood park, tallaght, dublin24\n"
+ "28 the richmond, smithfield, dubln 7\n"
+ "4 clogher road, crumlin, dublin 12\n"
+ "8 sutton court, sutton, dubin 13\n"
+ "19 st. marys road, dublin4\n"
+ "6 butterfield avenue, rathfarnham, dublin16\n"
+ "23 vernon gardens, clontarf, dublihn 3\n"
+ "apartment 75, 109 parnell street, dublin1\n"
+ "20 marian park, baldoyle, dublin13\n"
+ "15 simmonscourt, ballsbridge, dublin4\n"
+ "4 seaview terrace, howth, dublin13\n"
+ "4 & ground floor 5 marino mart, fairview, dublin3\n"
+ "119 bunting road, walkingtown, dublin12\n"
+ "12 beau park, clongriffin, dublin13\n"
+ "apt 1, 143 parnell st, dublin1\n"
+ "apt 91 spencer house, custom house sq, dublin1\n"
+ "7 beechpark avenue, castleknock, dublin15\n"
+ "68 lighthouse gateway, east wall road, dublin3\n"
+ "27a belvedere road, dublin1\n"
+ "apartment 2, henrietta street, dunlin 2\n"
+ "60 dublin rd, sutton, dubin 13\n"
+ "6 millbrook village, milltown, dunlin6 dublin_6\n"
+ "19b curzon street, dublin, dublin8\n"
+ "39 claremont court, glasnevin, dubin 9\n"
+ "aptment 48, harbour master square, ifsc dublin1\n"
+ "22 willfield, sandymount, dublin4\n"
+ "3 russell cresent, tallaght, dublin24\n"
+ "apt. 4, 5 granby row, dublin1\n"
+ "15 crumlin village, dubin 12\n"
+ "167 hampton wood road, hampton wood, dubli 11\n"
+ "25 hyde sq, south circular road, dubiln 8\n"
+ "83 red arches road, baldoyle, dublin13\n"
+ "276 bachelors walk, bachelors walk, dublin1\n"
+ "1 the mews, dodder vale, churchtown dulbin 14\n"
+ "21 annannamoe drive, annmoe, dublin7\n"
+ "114 the northumberlands, lower mount st, dublin2\n"
+ "11 the alders, carrington, santry dubllin 9\n"
+ "111 marlborough road, donnybrook, dublin 4\n"
+ "13 thomastown house, spencer dock, dublin1\n"
+ "104 hampton wood avenue, hampton wood, dublin11\n"
+ "19 red arches close, baldoyle, dublin13\n"
+ "63 bannow road, cabra west, dubin 7\n"
+ "10 greenfield park, donnybrook, dublin4\n"
+ "12 glencarrig court, dublin9\n"
+ "90 cushlawan park, tallaght, dubliln 24\n"
+ "no 11 orlagh na green, templeogue, dublin16\n"
+ "27 rocwood, foxrock, dubliln 18\n"
+ "apt 22 parkgate place, parkgate street, dubln 8\n"
+ "60 tenter fields, south brown street, dublin 8\n"
+ "6 claremont, carrickmines, dublin18\n"
+ "no.26 diswellstown manor, castleknock, dublin15\n"
+ "no 79a talbot street and, 43 lower gardiner street, dublin1\n"
+ "38 dobberbank, miltown, dublin6\n"
+ "6 the courtyard, clonsilla, dublin 15\n"
+ "6 court apartments, wilton place, dublin2\n"
+ "628a south circular road, kilmainham, dulbin 8\n"
+ "57 marlborough road, donnybrook, dublin4\n"
+ "16 vernon drive, clontarf, dublin 3\n"
+ "21 castlegrange avenue, castaheaney, dublin15\n"
+ "95 grove park, rathmines, dubline 6\n"
+ "1 eagle hill ave, terenure rd east, dubliln 6w\n"
+ "ground floor, 52 south richmond st., dublin2\n"
+ "43 tyrconnell road, inchcore, dyublin 8\n"
+ "apt. 44, 16 kings inn street, dublin1\n"
+ "wintergarden, dublin1, dublin_2\n"
+ "3 dubber cross, finglas, dublin11\n"
+ "4 parkside close, dublin 13\n"
+ "16 ardilea crescent, clonskeagh, dubiln 14\n"
+ "no 1 claremount, cornelscourt, dublin18\n"
+ "28 grange hill, harolds grange road, dublin16\n"
+ "10 garville drive, rathgar, dublin 6\n"
+ "15 north richmond st, dubliin 1, dublin\n"
+ "64 diswellstown way, castleknock, dublin15\n"
+ "9 belarmine woods, stepaside, dubln 18\n"
+ "4 belarmine woods, stepaside, dublin 18\n"
+ "88 stepaside park, stillorgan, dublin18\n"
+ "south earl house, south earl street, dbulin 8\n"
+ "apartment 20, 18-21 mount street lower, dublin2\n"
+ "40a cashel avenue, crumlin, dublin12\n"
+ "18 whitestown green, blanchardstown, dublin15\n"
+ "52 kingscourt, parnell street, dublin1\n"
+ "no. 8 tenenure gate, terenure, dubllin 6w\n"
+ "26 strandmill avenue, portmarnock, dublin13\n"
+ "unit 63, northbank castleforbes road, dublin1\n"
+ "unit no 46 2nd floor, north bank castleforbes road, dublin1\n"
+ "unit no. 136 second floor, northbank castleforbes road, dublin1\n"
+ "unit no. 33, fourth floor, northbank castleforbes road dublin1\n"
+ "75 wellview avenue, blanchardstown, dublin15\n"
+ "apartment 140 rathmines town centre, rathmines, dubin 6\n"
+ "unit 25 seascape, 366 clontarf road, dublin3\n"
+ "1 priory street, clongriffin, dublin13\n"
+ "apartment no 10 smithfield lofts, north king street, dublin 7\n"
+ "23 hampton wood lawn, hampton wood, dublin11\n"
+ "25 parslickstown green, mulhuddart, dublin15\n"
+ "10 bluebell rd, bluebell, dublin 12\n"
+ "42 glasnevin avenue, glasnevin, dublin9\n"
+ "8 orwell park gardens, rathgar, dublin6\n"
+ "66 wellview avenue, blanchardstown, dublin15\n"
+ "4 ely square, rathfarnham, dublni 14\n"
+ "104a howth road, clontarf, dublin3\n"
+ "385 trimbleston, goatstown road, dublin14\n"
+ "44 parslickstown green, mulhuddart, dublin15\n"
+ "16 mountjoy square, dublin1\n"
+ "10 hogan place, dublin2, dublin\n"
+ "39 blackberry hill, carrickmines, dublin 18\n"
+ "52 kennelsfort rd upr, palmerstown, dulin 20\n"
+ "19 sheepmoor grove, blanchardstown, dublin15\n"
+ "39 parslickstown avenue, mulhuddart, dublin15\n"
+ "unit 8 seascape, 366 clontarf road, dublin3\n"
+ "14 wellview grove, blanchardstown, dublin15\n"
+ "apt 19 mellor court, 19 23 liffey st lower, duboin 1\n"
+ "26 dal riada court, knocklyon, dublin16\n"
+ "25 drumcliffe drive, dublin, dbulin 7\n"
+ "3 whitestown green, blanchardstown, dublin15\n"
+ "28 dermot street, clongriffin, dublin13\n"
+ "30 swift hall, the coombe, dublin 8\n"
+ "144 hampton wood avenue, dublin, dublin11\n"
+ "27a belvedere road, dublin1\n"
+ "18 maxwell road, rathmines, dublin6\n"
+ "apartment 35 seascape, 366 clontarf road, dublin3\n"
+ "17 odins way, rathfarnham, dublion 16\n"
+ "178 batchelor walk, dbulin 1\n"
+ "39 rialto cottages, rialto, dublin8\n"
+ "7 coolatree rd, beaumont, dublin9\n"
+ "36 orlagh grange, knocklyon, dublin 16\n"
+ "3 bluebell crescent, bluebell avenue, dublin12\n"
+ "4 bluebell crescent, bluebell avenue, dublin12\n"
+ "5 bluebell crescent, bluebell avenue, dublin12\n"
+ "27 wellview avenue, blanchardstown, dublin15\n"
+ "6 millrace gardens, saggart, dublin24\n"
+ "dass 117 foxrock grove, dulbin 18\n"
+ "45 seascape, 366 clontarf road, dublin3\n"
+ "20 tara hill rd, rathfarnham, dublin14\n"
+ "5 the ropery, south lotts road, dublin4\n"
+ "69 palmerston rd, rathmines, dublin 6\n"
+ "40 castlegrange avenue, castlegrange, dublin15\n"
+ "apt 1, 12 adelaide road, dublin2\n"
+ "22 wellview park, blanchardstown, dublin15\n"
+ "8 grattan place, dublin2\n"
+ "4 seascape, clontarf road, dublin3\n"
+ "38 dobberbank, miltown, dublin6\n"
+ "aptment 48, harbour master square, ifsc dublin1\n"
+ "41a ballyboden crescent, rathfarnham, dublin16\n"
+ "59 seascape, clontarf, dublin3\n"
+ "180 st. margarets road, hampton wood, dublin11\n"
+ "76 whitestown park, blanchardstown, dublin15\n"
+ "15 barnwell grove, hansfield, dublin 15\n"
+ "67 glenealy road, crumlin, dublin12\n"
+ "3 rock ville court, glenamock road, dublin18\n"
+ "apartment 1, 314 south circular road, dublin 8\n"
+ "53 hollywood rath avenue, hollystown, dublin15\n"
+ "7 whitestown grove, blanchardstown, dublin15\n"
+ "68 lighthouse gateway, east wall road, dublin3\n"
+ "23 dodderbrook avenue, ballycullen, dublin24\n"
+ "1 airpark square, rathfarnham, dublin16\n"
+ "47 fairhaven avenue, castleknock, dublin15\n"
+ "18 edenbrook green, citywest, dublin24\n"
+ "88 park drive ave, castleknock, dublin15\n"
+ "1 de burgh rd, dublin7, dublin\n"
+ "apt1, 6 sherrard street upper, dubiln 1\n"
+ "apartment 7, 55 percy place, dublin4\n"
+ "18 (f) south lotts road, ringsend, dublin4\n"
+ "the kokonut, 6 long mile road, dublin 12\n"
+ "15 riverwood square, castleknock, dublin15\n"
+ "6 elder heath court, elder heath, dublin24\n"
+ "29 churchfields, milltown, dunlin 6 dublin_6\n"
+ "8 wellview avenue, blanchardstown, dublin15\n"
+ "39 sheepmoor grove, blanchardstown, dublin15\n"
+ "9 abbotts grove avenue, knocklyon, dublin16\n"
+ "5 hollywoodrath avenue, hollystown, dublin15\n"
+ "7 carlton mews, shelbourne avenue, dublin 4\n"
+ "apartment 2, henrietta street, dunlin 2\n"
+ "flat 1, 11 north frederick street, dublin1\n"
+ "25 hyde sq, south circular road, dubiln 8\n"
+ "17 parslickstown avenue, mulhuddart, dublin15\n"
+ "25 hollywoodrath crescent, hollystown, dublin15\n"
+ "36 fairhaven walk, castleknock road, dublin15\n"
+ "1 whitechapel grove, coolmine, dublin15\n"
+ "89 the old distillery, beresford st, dublin7\n"
+ "8 castleknock cross, castleknock, dubin 15\n"
+ "apt 1, 18 synge st, dubli 8\n"
+ "1b sheepmoor close, blanchardstown, dublin15\n"
+ "4 hollywoodrath road, hollystown, dublin15\n"
+ "no. 125 hampton wood avenue, hampton wood, dublin11\n"
+ "39 malahide road, clontarf, dubllin 3\n"
+ "36 fairhaven road, castleknock, dublin15\n"
+ "36 hampton wood lawn, finglas, dublin11\n"
+ "414 trimbleston, goatstown road, dublin14\n"
+ "11 maxwell square, rathmines, dublin6\n"
+ "57 moyclare close, baldoyle, dublin13\n"
+ "125 brandon square, blanchardstown, dublin15\n"
+ "2 cuil duin row, citywest, dublin24\n"
+ "44 parslickstown drive, mulhuddart, dublin15\n"
+ "2 king street, clongriffin, dublin13\n"
+ "9 the drive, bellingsmore, church road kilmartindublin15\n"
+ "apartment 115, longboat quay north, dublin2\n"
+ "7 diswellstown grove, castleknock, dublin15\n"
+ "34 portersgate avenue, clonsilla, dublin15\n"
+ "30 temple woods, greenhills road, dublin24\n"
+ "12 park house, baldoyle, dublin13\n"
+ "4 castle avenue, upper churchtown rd, dubliln 14\n"
+ "16 fairhaven close, castleknock, dublin15\n"
+ "apartment 60 ard cluain, main street clonee, dublin 15";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}