const regex = /[, ]*\b[db]+y?[iunb]{1,2}[okgbil]{1,3}[nhei]{1,2} *(\d)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[, ]*\\b[db]+y?[iunb]{1,2}[okgbil]{1,3}[nhei]{1,2} *(\\d)', 'gmi')
const str = `27 gloonlara road, finglas, dulbin 11
apt 3 block 10 gallery quay, grand canal square dublini 2
17 block c doonbeg house, clare village, clare hall dublin17
1 waverley terrace, kenilworth square, dublin6
19 ardmore close, artane, dublin 5
71 powers court, mount street, dublin2
apartment 93, 20 christchurch place, dubin 8
15 ebenezer terrace, donor avenue, inchicore dubllin 8
54 burnell park avenue, castleknock, dubin 15
351 bachelors walk, dublin1
apt 43 st. anthony's walk, rialto, dublin8
apartment33 block d, doolin house, clare village clare hall dublin17
40 coolatree park, beaumont, bublin 9
57 bellville, navan road, dublin15
2 belgard close, tallaght, dublin24
51 the coombe, dubliln 8
21 walkinstown park, walkinstown, diblin 12
apt 77 millpark, clondalkin, dublin 22
71 tudor lawns, foxrock, dublni 18
38 bayside crescent, sutton, dublin13
5 bancroft close, tallaght, dublin 24
apt 18 no 68 jervis street, dublin1
8 the friary, bluebell, dublin12
64 cremorne, terenure, dubin 6
1 elmwood close, clonsilla, dublinn 15
19 woodstown place, knocklyon, dubin 16
11 monksfield heights, clondalkin, dublin22
2 st. declans tce, marino, dublin3
apartment 28, block a kilkee house, clare village clare hall dublin17
33 tulla house, clare village, dubllin 17
71 donnycarney road, whitehall, dubin 9
46 casement park, finglas, dublin11
15 block e3 ennis house, clare village, clare hall dublin17
13 blarney park, kimmage, dubin 12
47 ennis house, clare village clare hall, dublin17
6 ennis house, clare village, dublin13
30 newlands road, clondalkin, dubllin 22
33 kings avenue, dubiln 3
46 block e3 ennis house, clare village clare hall, dublin17
69 churchwell road, belmayne, balgriffin dublin13
64 st. davids park, artane, dublin 5
11 cairnbrook avenue, carrickmines, dublin 18
78 hunter's walk, hunterswood, ballycullen dubin 24
no198, lower kimmage road, dublin6
20 kelston drive, foxrock, dubllin 18
no 5 swift hall carrickmines wood, brennanstown road dubiln 18
32 ballytore road, rathfarnham park, dublin 14
70 hillcrest park, glasnevin, dublin11
4 st. patrick's cottages, rathfarnham, dbulin 14
35 johnstown court, cabinteely, dublon 18
28 ashford st, dublin 7
32 villiers road, rathgar, dublin6
apt 19 mellor court, 19-23 liffey street lower, duboin 1
15 all saints road, raheny, dublin5
64 saul road, crumlin, dublin12
10 blackheath court, clontarf, dublin3
11 grangeview close, clondalkin, dublin 22
128 kildare road, crumlin, dublin12
39 woodstown way, knocklyon, dublin16
23 rothe abbey, kilmainham, dublin8
50 collinswood, collins avenue, dublin9
24 tritonville road, sandymount, dublin 4
139 belmont park, raheny, dublin5
1 deerhaven crescent, clonee, dublin15
15 monastery heath square, clondalkin, dublin22
15 brookwood park, artane, dublin 5
300 navan road, dublin7
17b merlyn park, ballsbridge, dunlin 4
84 tritonville road, sandymount, dublbin 4
16 windsor terrace, portobello, dublin8
1 whitton road, terenure, diblin 6w
1 eagle hill avenue, terenure road east, dubliln 6w
25 gullistan cottages, rathmines, dublin6
409 castleforbes square, upper mayor street, dublin1
439 castleforbes square, upper mayor street, dublin1
94 phibsboro road, phibsboro, dublin7
45 shanglass road, whitehall, dublin9
12 st bricins park, dubliin 7
20 greenhills road, walkinstown, dubln 12
112 malahide road, clontarf, dubiln 3
55 mountshannon road, rialto, dublin8
46 foster terrace, dubiln 3
3 rosemount, malahide road, dubin 5
4 castle avenue, upr churchtown road, dubliln 14
188 bushy park house, templogue road, terenure dublin6
11 greenlea park, terenure, dubln 6w
54 wood dale view, ballycragh, dubln 24
2 glenfield avenue, clondalkin, dublin 22
34 grange manor drive, rathfarnham, dublin16
33 monksfield grove, clondalkin, dublin22
41 philipsburgh terrace, marino, dublin3
85 bluebell road, bluebell, dublin12
11 the garth kingswood heights, clondalkin, dublin22
5 mount eagle grove, leopardstown heights, leopardstown dublin18
34 donore road, south circular road, dublin8
65 sutton park, sutton, dublin13
51 briarfield road, kilbarrack, dubln 5
4 drumfinn avenue, ballyfermot, dulin 10
31 gullistan cottages, rathmines, dublin6
40 pinewood park, rathfarnham, dubiln 14
64 the waterside, charlotte quay, dublin4
2 barnwell way, hansfield, dubin 15
111 pine valley avenue, rathfarnham, dubkin 16
30 ratra park, dublin 7
3 blakestown road, mulhuddart, dubliln 15
22 foyle road, fairview, dubln 3
apt. 125 bachelor's walk, dublin 1
31 summerhill parade, dulin 1
88 meadow grove, dundrum, dubglin 14
4 kickham road, inchicore, dublin 8
52 hazelwood avenue, clonsilla, dublin15
4 rathdown square, phibsboro, dublin 7
14a kincora court, clontarf, dublin3
apartment 26, 35 mountjoy square, dublin1
3 drummartin crescent, goatstown, dublin 14
15 the court, kingswood heights, dublin24
78 greentrees road, perrystown, dublin12
27 kiltipper avenue, tallaght, dubblin 24
112 rafters road, drimnagh, dublin12
3 barnwell terrace, hansfield, dubin 15
40 the maples, clonskeagh, dublin 14
48 alderwood, hollystown, dublin15
43 millcourt avenue, clondalkin, dublin 22
129 belmont park, raheny, dublin 5
67 swanward court, parnell road, dublin 8
111 whitethorn drive, palmerstown, dublin 22
36 sundale avenue, tallaght, dublin24
26 mount alton, knocklyon, dublin16
41 kirkpatrick house, spencer dock, dublin1
34 niall street, stoneybatter, dublin7
59a foxrock park, foxrock, dublin18
11 the cobbles, wellington quay, dublin2
24 palmers court, palmerstown, dublin 20
11 fernwood park, tallaght, dublin24
28 the richmond, smithfield, dubln 7
4 clogher road, crumlin, dublin 12
8 sutton court, sutton, dubin 13
19 st. marys road, dublin4
6 butterfield avenue, rathfarnham, dublin16
23 vernon gardens, clontarf, dublihn 3
apartment 75, 109 parnell street, dublin1
20 marian park, baldoyle, dublin13
15 simmonscourt, ballsbridge, dublin4
4 seaview terrace, howth, dublin13
4 & ground floor 5 marino mart, fairview, dublin3
119 bunting road, walkingtown, dublin12
12 beau park, clongriffin, dublin13
apt 1, 143 parnell st, dublin1
apt 91 spencer house, custom house sq, dublin1
7 beechpark avenue, castleknock, dublin15
68 lighthouse gateway, east wall road, dublin3
27a belvedere road, dublin1
apartment 2, henrietta street, dunlin 2
60 dublin rd, sutton, dubin 13
6 millbrook village, milltown, dunlin6 dublin_6
19b curzon street, dublin, dublin8
39 claremont court, glasnevin, dubin 9
aptment 48, harbour master square, ifsc dublin1
22 willfield, sandymount, dublin4
3 russell cresent, tallaght, dublin24
apt. 4, 5 granby row, dublin1
15 crumlin village, dubin 12
167 hampton wood road, hampton wood, dubli 11
25 hyde sq, south circular road, dubiln 8
83 red arches road, baldoyle, dublin13
276 bachelors walk, bachelors walk, dublin1
1 the mews, dodder vale, churchtown dulbin 14
21 annannamoe drive, annmoe, dublin7
114 the northumberlands, lower mount st, dublin2
11 the alders, carrington, santry dubllin 9
111 marlborough road, donnybrook, dublin 4
13 thomastown house, spencer dock, dublin1
104 hampton wood avenue, hampton wood, dublin11
19 red arches close, baldoyle, dublin13
63 bannow road, cabra west, dubin 7
10 greenfield park, donnybrook, dublin4
12 glencarrig court, dublin9
90 cushlawan park, tallaght, dubliln 24
no 11 orlagh na green, templeogue, dublin16
27 rocwood, foxrock, dubliln 18
apt 22 parkgate place, parkgate street, dubln 8
60 tenter fields, south brown street, dublin 8
6 claremont, carrickmines, dublin18
no.26 diswellstown manor, castleknock, dublin15
no 79a talbot street and, 43 lower gardiner street, dublin1
38 dobberbank, miltown, dublin6
6 the courtyard, clonsilla, dublin 15
6 court apartments, wilton place, dublin2
628a south circular road, kilmainham, dulbin 8
57 marlborough road, donnybrook, dublin4
16 vernon drive, clontarf, dublin 3
21 castlegrange avenue, castaheaney, dublin15
95 grove park, rathmines, dubline 6
1 eagle hill ave, terenure rd east, dubliln 6w
ground floor, 52 south richmond st., dublin2
43 tyrconnell road, inchcore, dyublin 8
apt. 44, 16 kings inn street, dublin1
wintergarden, dublin1, dublin_2
3 dubber cross, finglas, dublin11
4 parkside close, dublin 13
16 ardilea crescent, clonskeagh, dubiln 14
no 1 claremount, cornelscourt, dublin18
28 grange hill, harolds grange road, dublin16
10 garville drive, rathgar, dublin 6
15 north richmond st, dubliin 1, dublin
64 diswellstown way, castleknock, dublin15
9 belarmine woods, stepaside, dubln 18
4 belarmine woods, stepaside, dublin 18
88 stepaside park, stillorgan, dublin18
south earl house, south earl street, dbulin 8
apartment 20, 18-21 mount street lower, dublin2
40a cashel avenue, crumlin, dublin12
18 whitestown green, blanchardstown, dublin15
52 kingscourt, parnell street, dublin1
no. 8 tenenure gate, terenure, dubllin 6w
26 strandmill avenue, portmarnock, dublin13
unit 63, northbank castleforbes road, dublin1
unit no 46 2nd floor, north bank castleforbes road, dublin1
unit no. 136 second floor, northbank castleforbes road, dublin1
unit no. 33, fourth floor, northbank castleforbes road dublin1
75 wellview avenue, blanchardstown, dublin15
apartment 140 rathmines town centre, rathmines, dubin 6
unit 25 seascape, 366 clontarf road, dublin3
1 priory street, clongriffin, dublin13
apartment no 10 smithfield lofts, north king street, dublin 7
23 hampton wood lawn, hampton wood, dublin11
25 parslickstown green, mulhuddart, dublin15
10 bluebell rd, bluebell, dublin 12
42 glasnevin avenue, glasnevin, dublin9
8 orwell park gardens, rathgar, dublin6
66 wellview avenue, blanchardstown, dublin15
4 ely square, rathfarnham, dublni 14
104a howth road, clontarf, dublin3
385 trimbleston, goatstown road, dublin14
44 parslickstown green, mulhuddart, dublin15
16 mountjoy square, dublin1
10 hogan place, dublin2, dublin
39 blackberry hill, carrickmines, dublin 18
52 kennelsfort rd upr, palmerstown, dulin 20
19 sheepmoor grove, blanchardstown, dublin15
39 parslickstown avenue, mulhuddart, dublin15
unit 8 seascape, 366 clontarf road, dublin3
14 wellview grove, blanchardstown, dublin15
apt 19 mellor court, 19 23 liffey st lower, duboin 1
26 dal riada court, knocklyon, dublin16
25 drumcliffe drive, dublin, dbulin 7
3 whitestown green, blanchardstown, dublin15
28 dermot street, clongriffin, dublin13
30 swift hall, the coombe, dublin 8
144 hampton wood avenue, dublin, dublin11
27a belvedere road, dublin1
18 maxwell road, rathmines, dublin6
apartment 35 seascape, 366 clontarf road, dublin3
17 odins way, rathfarnham, dublion 16
178 batchelor walk, dbulin 1
39 rialto cottages, rialto, dublin8
7 coolatree rd, beaumont, dublin9
36 orlagh grange, knocklyon, dublin 16
3 bluebell crescent, bluebell avenue, dublin12
4 bluebell crescent, bluebell avenue, dublin12
5 bluebell crescent, bluebell avenue, dublin12
27 wellview avenue, blanchardstown, dublin15
6 millrace gardens, saggart, dublin24
dass 117 foxrock grove, dulbin 18
45 seascape, 366 clontarf road, dublin3
20 tara hill rd, rathfarnham, dublin14
5 the ropery, south lotts road, dublin4
69 palmerston rd, rathmines, dublin 6
40 castlegrange avenue, castlegrange, dublin15
apt 1, 12 adelaide road, dublin2
22 wellview park, blanchardstown, dublin15
8 grattan place, dublin2
4 seascape, clontarf road, dublin3
38 dobberbank, miltown, dublin6
aptment 48, harbour master square, ifsc dublin1
41a ballyboden crescent, rathfarnham, dublin16
59 seascape, clontarf, dublin3
180 st. margarets road, hampton wood, dublin11
76 whitestown park, blanchardstown, dublin15
15 barnwell grove, hansfield, dublin 15
67 glenealy road, crumlin, dublin12
3 rock ville court, glenamock road, dublin18
apartment 1, 314 south circular road, dublin 8
53 hollywood rath avenue, hollystown, dublin15
7 whitestown grove, blanchardstown, dublin15
68 lighthouse gateway, east wall road, dublin3
23 dodderbrook avenue, ballycullen, dublin24
1 airpark square, rathfarnham, dublin16
47 fairhaven avenue, castleknock, dublin15
18 edenbrook green, citywest, dublin24
88 park drive ave, castleknock, dublin15
1 de burgh rd, dublin7, dublin
apt1, 6 sherrard street upper, dubiln 1
apartment 7, 55 percy place, dublin4
18 (f) south lotts road, ringsend, dublin4
the kokonut, 6 long mile road, dublin 12
15 riverwood square, castleknock, dublin15
6 elder heath court, elder heath, dublin24
29 churchfields, milltown, dunlin 6 dublin_6
8 wellview avenue, blanchardstown, dublin15
39 sheepmoor grove, blanchardstown, dublin15
9 abbotts grove avenue, knocklyon, dublin16
5 hollywoodrath avenue, hollystown, dublin15
7 carlton mews, shelbourne avenue, dublin 4
apartment 2, henrietta street, dunlin 2
flat 1, 11 north frederick street, dublin1
25 hyde sq, south circular road, dubiln 8
17 parslickstown avenue, mulhuddart, dublin15
25 hollywoodrath crescent, hollystown, dublin15
36 fairhaven walk, castleknock road, dublin15
1 whitechapel grove, coolmine, dublin15
89 the old distillery, beresford st, dublin7
8 castleknock cross, castleknock, dubin 15
apt 1, 18 synge st, dubli 8
1b sheepmoor close, blanchardstown, dublin15
4 hollywoodrath road, hollystown, dublin15
no. 125 hampton wood avenue, hampton wood, dublin11
39 malahide road, clontarf, dubllin 3
36 fairhaven road, castleknock, dublin15
36 hampton wood lawn, finglas, dublin11
414 trimbleston, goatstown road, dublin14
11 maxwell square, rathmines, dublin6
57 moyclare close, baldoyle, dublin13
125 brandon square, blanchardstown, dublin15
2 cuil duin row, citywest, dublin24
44 parslickstown drive, mulhuddart, dublin15
2 king street, clongriffin, dublin13
9 the drive, bellingsmore, church road kilmartindublin15
apartment 115, longboat quay north, dublin2
7 diswellstown grove, castleknock, dublin15
34 portersgate avenue, clonsilla, dublin15
30 temple woods, greenhills road, dublin24
12 park house, baldoyle, dublin13
4 castle avenue, upper churchtown rd, dubliln 14
16 fairhaven close, castleknock, dublin15
apartment 60 ard cluain, main street clonee, dublin 15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}