import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]{6}[0-9LMNPQRSTUV]{2}[ABCDEHLMPRST]{1}([1-9]|[12][0-9]|3[01]|4[1-9]|[56][0-9]|7[01]|LMNPQRSTUV){2}[A-Z]{1}[0-9LMNPQRSTUV]{3}[A-Z]{1}";
final String string = "MSLNDR00M19H501I\n"
+ "CNTMNL62C69H501O";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}