import Foundation
let pattern = #"[A-Z]{6}[0-9LMNPQRSTUV]{2}[ABCDEHLMPRST]{1}([1-9]|[12][0-9]|3[01]|4[1-9]|[56][0-9]|7[01]|LMNPQRSTUV){2}[A-Z]{1}[0-9LMNPQRSTUV]{3}[A-Z]{1}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
MSLNDR00M19H501I
CNTMNL62C69H501O
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)