re = /[A-Z]{6}[0-9LMNPQRSTUV]{2}[ABCDEHLMPRST]{1}([1-9]|[12][0-9]|3[01]|4[1-9]|[56][0-9]|7[01]|LMNPQRSTUV){2}[A-Z]{1}[0-9LMNPQRSTUV]{3}[A-Z]{1}/m
str = 'MSLNDR00M19H501I
CNTMNL62C69H501O'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end