import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\pL+)(\\d+)";
final String string = "Форд23324\n"
+ "Форд23325\n"
+ "Форд23326\n"
+ "Форд23327\n"
+ "Форд23328\n"
+ "Форд23329\n"
+ "Форд23330\n"
+ "Форд23331\n"
+ "Форд23332\n"
+ "Форд23333\n"
+ "Форд23334\n"
+ "Форд23335\n"
+ "Форд23336\n";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}