$re = '/(?<!\d)\d{2}(?!\d)|\d{4}/m';
$str = '1 12 123 1234 12345 123456 1234567 12345678 123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);