import re
regex = re.compile(r"(?<!\d)\d{2}(?!\d)|\d{4}", flags=re.MULTILINE)
test_str = "1 12 123 1234 12345 123456 1234567 12345678 123456789"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")