re = /(?<!\d)\d{2}(?!\d)|\d{4}/m
str = '1 12 123 1234 12345 123456 1234567 12345678 123456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end