const regex = new RegExp('(?P<name>[\\w-]+?)\\s*=\\s*{(?:{| {\\[})?\\s*(?P<content>.*?)(?:,])?\\s*}{1,2}', 'gm')
const str = `fieldName1 = {{ content1 }},\\n
fieldName2 = { content2 },\\n
fieldName3 = { {[}content3,] },\\n
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}