$re = '/(?P<name>[\w-]+?)\s*=\s*{(?:{| {\[})?\s*(?P<content>.*?)(?:,])?\s*}{1,2}/m';
$str = 'fieldName1 = {{ content1 }},\\n
fieldName2 = { content2 },\\n
fieldName3 = { {[}content3,] },\\n
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);