re = /(?P<name>[\w-]+?)\s*=\s*{(?:{| {\[})?\s*(?P<content>.*?)(?:,])?\s*}{1,2}/m
str = 'fieldName1 = {{ content1 }},\\n
fieldName2 = { content2 },\\n
fieldName3 = { {[}content3,] },\\n
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end