package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"title":{"rendered":"(.*?)\.?"}`)
var str = `"title":{"rendered":"Marine Corp."}
"title":{"rendered":"Marine Police"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}