const regex = /"title":{"rendered":"(.*?)\.?"}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"title":{"rendered":"(.*?)\\.?"}', 'g')
const str = `"title":{"rendered":"Marine Corp."}
"title":{"rendered":"Marine Police"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}