re = /"title":{"rendered":"(.*?)\.?"}/
str = '"title":{"rendered":"Marine Corp."}
"title":{"rendered":"Marine Police"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end