// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)(?<header_all>
^
(?<!\\)
(?<header_level>\#+)
[ \t]*
(?<header_content>.*?)
[ \t\#]*
(?<!\\)
\{
[[:blank:]\h]*
(?<header_attr>[^\}]*)
\}
\n
)").unwrap();
let string = "### Header {#id3 }
#### Header ## { #id4 }
### Header {.cl }
### Header {.cl .class }
### Header {.cl.class#id7 }
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}