#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\d{0,3}(?:\.\d{1,2})?$"
Local $sString = "123" & @CRLF & _
"123.33" & @CRLF & _
"1234" & @CRLF & _
"1234.333" & @CRLF & _
"123.3" & @CRLF & _
"12" & @CRLF & _
"12.33" & @CRLF & _
"12.334"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)