import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{0,3}(?:\\.\\d{1,2})?$";
final String string = "123\n"
+ "123.33\n"
+ "1234\n"
+ "1234.333\n"
+ "123.3\n"
+ "12\n"
+ "12.33\n"
+ "12.334";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}