const regex = /^\d{0,3}(?:\.\d{1,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{0,3}(?:\\.\\d{1,2})?$', 'gm')
const str = `123
123.33
1234
1234.333
123.3
12
12.33
12.334`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);