import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^exmpl-(?P<type>main|staging|demo|production)(?:-(?P<case>\\d+|main))?(?:-(?P<title>(?!e2e-\\d+).+?))?(?:-e2e-(?P<timestamp>\\d+))?$";
final String string = "exmpl-staging-1234-my-case-title-e2e-1707336983872";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}