const regex = new RegExp('^exmpl-(?P<type>main|staging|demo|production)(?:-(?P<case>\\d+|main))?(?:-(?P<title>(?!e2e-\\d+).+?))?(?:-e2e-(?P<timestamp>\\d+))?$', 'gm')
const str = `exmpl-staging-1234-my-case-title-e2e-1707336983872`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}