#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)/([a-zA-Z0-9_-]+)[.](css|js)"
Local $sString = "duis ut diam quam /app.css porttitor" & @CRLF & _
"app.css" & @CRLF & _
"main.js" & @CRLF & _
"purus sit (amet volutpat /main.js)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")