package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)`)
var str = `Agência: 0000 Conta: 00000-0
Conta: 00000-0 Agência: 0000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}