$re = '/(\d+)/';
$str = 'Agência: 0000 Conta: 00000-0
Conta: 00000-0 Agência: 0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);