// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+)").unwrap();
let string = "AgĂȘncia: 0000 Conta: 00000-0
Conta: 00000-0 AgĂȘncia: 0000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}