using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^0-9][0-9]{6}-[0-9][^0-9]";
string input = @"asdf 123456-7 asdf
asdf123456-7asdf
asdf 112423456-7 asdf
asdf,123456-7,asdf
123456-7
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}