$re = '/[^0-9][0-9]{6}-[0-9][^0-9]/m';
$str = 'asdf 123456-7 asdf
asdf123456-7asdf
asdf 112423456-7 asdf
asdf,123456-7,asdf
123456-7
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);