// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^0-9][0-9]{6}-[0-9][^0-9]").unwrap();
let string = "asdf 123456-7 asdf
asdf123456-7asdf
asdf 112423456-7 asdf
asdf,123456-7,asdf
123456-7
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}