import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)(ND_\\d_)(Dist_\\d_)(.*)";
final String string = "Par1_MD_0_5_AL_2_ND_4_Dist_0_Pot_Drop_out.txt\n"
+ "Par1_MD_0_5_AL_2_ND_4_Dist_1_Pot_Drop_out.txt\n"
+ "Par1_MD_0_5_AL_2_ND_6_Dist_2_Pot_Drop_out.txt\n"
+ "Par1_MD_0_5_AL_2_ND_8_Dist_3_Pot_Drop_out.txt\n";
final String subst = "$1$3$2$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}