# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*?)(ND_\d_)(Dist_\d_)(.*)"
test_str = ("Par1_MD_0_5_AL_2_ND_4_Dist_0_Pot_Drop_out.txt\n"
"Par1_MD_0_5_AL_2_ND_4_Dist_1_Pot_Drop_out.txt\n"
"Par1_MD_0_5_AL_2_ND_6_Dist_2_Pot_Drop_out.txt\n"
"Par1_MD_0_5_AL_2_ND_8_Dist_3_Pot_Drop_out.txt\n")
subst = "$1$3$2$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.